Διαφορά μεταξύ των αναθεωρήσεων του "Linux/Προχωρημένα/Περιοδικές εργασίες"

μ (Ρομπότ: Αυτόματη αντικατάσταση κειμένου (-UserResponse +Button))
 
(15 ενδιάμεσες εκδόσεις από 2 χρήστες δεν εμφανίζονται)
Γραμμή 1: Γραμμή 1:
 +
{{Warning|Εάν έχετε εγκαταστήσει [[Linux/LTSP|εξυπηρετητή ΣΕΠΕΗΥ]] τότε οι παρακάτω ενέργειες γίνονται αυτόματα με τα [[Linux/sch-scripts|{{Application|sch-scripts}}]], σύμφωνα με τις οδηγίες [[Linux/sch-scripts/Συντήρηση ΣΕΠΕΗΥ]]}}
 +
<br>
 
==Απομάκρυνση μη χρησιμοποιούμενων πακέτων==
 
==Απομάκρυνση μη χρησιμοποιούμενων πακέτων==
 
Κάποια από τα αρχικά εγκατεστημένα πακέτα αντικαθίστανται με νεότερες εκδόσεις. Διαγράψτε τα μη χρησιμοποιούμενα πακέτα με την εντολή:
 
Κάποια από τα αρχικά εγκατεστημένα πακέτα αντικαθίστανται με νεότερες εκδόσεις. Διαγράψτε τα μη χρησιμοποιούμενα πακέτα με την εντολή:
 +
 
{{Terminal|sudo apt-get autoclean}}
 
{{Terminal|sudo apt-get autoclean}}
 +
<br/>
 +
Εάν επιθυμείτε να διαγράψετε και πακέτα που είχαν εγκατασταθεί ως εξαρτήσεις (dependencies) άλλων πακέτων που εν τω μεταξύ έχουν διαγραφεί ή αντικατασταθεί, χρησιμοποιήστε την εντολή:
  
Εάν επιθυμείτε να διαγράψετε και πακέτα που είχαν εγκατασταθεί ως εξαρτήσεις (dependencies) άλλων πακέτων που εν τω μεταξύ έχουν διαγραφεί ή αντικατασταθεί, χρησιμοποιήστε την εντολή:
 
 
{{Terminal|sudo apt-get autoremove}}
 
{{Terminal|sudo apt-get autoremove}}
 +
 
==Αφαίρεση παλαιών πυρήνων==
 
==Αφαίρεση παλαιών πυρήνων==
 
Για να διαγράψετε τους παλιούς πυρήνες (δεν χρησιμοποιούνται πλέον) και για να μειώσετε το μενού των επιλογών του grub κατά την εκκίνηση κάντε τα ακόλουθα βήματα:
 
Για να διαγράψετε τους παλιούς πυρήνες (δεν χρησιμοποιούνται πλέον) και για να μειώσετε το μενού των επιλογών του grub κατά την εκκίνηση κάντε τα ακόλουθα βήματα:
* Από την Προσθαφαίρεση Προγραμμάτων αναζητήστε τα linux-image και επιλέξτε εξ' αυτών όσα δεν χρειάζεστε
+
* Από την {{Application|Προσθαφαίρεση Προγραμμάτων}} αναζητήστε τη λέξη {{Button|linux-image}}
* Αφαιρέστε τα συγκεκριμένα πακέτα {{Menu|δεξί click στα επιλεγμένα πακέτα|Σημείωση για απομάκρυνση}}
+
* Επιλέξτε Κατάσταση Πακέτων {{Button|Εγκατεστημένα}} (για να δείτε μόνο τα εγκατεστημένα πακέτα)
 +
* Κάντε click σε κάθε πακέτο που δεν χρειάζεστε και κατόπιν δεξί click {{Button|Σημείωση για ολοκληρωτική απομάκρυνση}}
 +
* Επαναλάβατε την ίδια διαδικασία για τα "linux-headers" (αφαιρώντας τις αντίστοιχες εκδόσεις) από τα πακέτα linux-headers-<version> και linux-headers-<version>-generic-pae
 +
* Επιλέξτε {{Button|Εφαρμογή}}
 +
<br>
 +
{{Hint|Αφήστε τουλάχιστον μία προηγούμενη έκδοση πυρήνα για περιπτώσεις που διαπιστώσετε ότι η τρέχουσα έκδοση σας δημιουργεί προβλήματα}}

Τελευταία αναθεώρηση της 17:38, 4 Φεβρουαρίου 2014


Dialog-warning.pngΕάν έχετε εγκαταστήσει εξυπηρετητή ΣΕΠΕΗΥ τότε οι παρακάτω ενέργειες γίνονται αυτόματα με τα sch-scripts, σύμφωνα με τις οδηγίες Linux/sch-scripts/Συντήρηση ΣΕΠΕΗΥ



Απομάκρυνση μη χρησιμοποιούμενων πακέτων

Κάποια από τα αρχικά εγκατεστημένα πακέτα αντικαθίστανται με νεότερες εκδόσεις. Διαγράψτε τα μη χρησιμοποιούμενα πακέτα με την εντολή:


Terminal.pngsudo apt-get autoclean



Εάν επιθυμείτε να διαγράψετε και πακέτα που είχαν εγκατασταθεί ως εξαρτήσεις (dependencies) άλλων πακέτων που εν τω μεταξύ έχουν διαγραφεί ή αντικατασταθεί, χρησιμοποιήστε την εντολή:


Terminal.pngsudo apt-get autoremove


Αφαίρεση παλαιών πυρήνων

Για να διαγράψετε τους παλιούς πυρήνες (δεν χρησιμοποιούνται πλέον) και για να μειώσετε το μενού των επιλογών του grub κατά την εκκίνηση κάντε τα ακόλουθα βήματα:

  • Από την Προσθαφαίρεση Προγραμμάτων αναζητήστε τη λέξη linux-image
  • Επιλέξτε Κατάσταση Πακέτων Εγκατεστημένα (για να δείτε μόνο τα εγκατεστημένα πακέτα)
  • Κάντε click σε κάθε πακέτο που δεν χρειάζεστε και κατόπιν δεξί click Σημείωση για ολοκληρωτική απομάκρυνση
  • Επαναλάβατε την ίδια διαδικασία για τα "linux-headers" (αφαιρώντας τις αντίστοιχες εκδόσεις) από τα πακέτα linux-headers-<version> και linux-headers-<version>-generic-pae
  • Επιλέξτε Εφαρμογή



Info-32.pngΑφήστε τουλάχιστον μία προηγούμενη έκδοση πυρήνα για περιπτώσεις που διαπιστώσετε ότι η τρέχουσα έκδοση σας δημιουργεί προβλήματα